Login | Register
My pages Projects Community openCollabNet

Discussions > dev > 'configure' should be checking for gdbm library

subcommander
Discussion topic

Back to topic list

'configure' should be checking for gdbm library

Author ldavis
Full name Leo Davis
Date 2005-04-28 11:05:46 PDT
Message Hello,

I just tried to compile subcommander 0.9.0 on SuSE Linux 9.2 and got the
following error:

g++ -g -O2 -o sm ColorStorage.o ConflictMarkerWidget.o Diff3.o
Diff3Widget.o Diff.o DiffInfo.o DiffInfoModelImpl.o DoubleTextWidget.o
FileSelectDialog.o LinePainter.o LineTokenizer.o MainWindow.o
SingleTextWidget.o submerge.o TextGlueWidget.o TextLineNrWidget.o
TextViewWidget.o TextWidget.o -L../util -L../svn -L../sublib -lutil
-lsvn -lsublib -L/usr/lib/qt3/lib -lqt-mt -lSM -lICE -L/usr/X11R6/lib
-lX11 -lXext -lXmu -lXt -lXi -L/usr/lib -lapr-0 -lrt -lm -lcrypt
-lnsl -lpthread -ldl -L/usr/lib -laprutil-0 -lgdbm -ldb-4.2 -lexpat
-L/usr/local/lib -lsvn_diff-1
/usr/lib/gcc-lib/i58​6-suse-linux/3.3.4/.​./../../../i586-suse​-linux/bin/ld:
cannot find -lgdbm
collect2: ld returned 1 exit status

After I installed gdbm-devel (containing development libs/headers) it
compiled.
No big deal, I just thought you might want to add it to your
configuration script.

Leo

« Previous message in topic | 1 of 2 | Next message in topic »

Messages

Show all messages in topic

'configure' should be checking for gdbm library ldavis Leo Davis 2005-04-28 11:05:46 PDT
     Re: 'configure' should be checking for gdbm library hauner Martin Hauner 2005-04-29 12:52:05 PDT
Messages per page: